salt.states.pecl

Installation of PHP Extensions Using pecl

These states manage the installed pecl extensions. Note that php-pear must be installed for these states to be available, so pecl states should include a requisite to a pkg.installed state for the package which provides pecl (php-pear in most cases). Example:

php-pear:
  pkg.installed

mongo:
  pecl.installed:
    - require:
      - pkg: php-pear
salt.states.pecl.installed(name, version=None, defaults=False, force=False, preferred_state=u'stable')

New in version 0.17.0.

Make sure that a pecl extension is installed.

name
The pecl extension name to install
version
The pecl extension version to install. This option may be ignored to install the latest stable version.
defaults
Use default answers for extensions such as pecl_http which ask questions before installation. Without this option, the pecl.installed state will hang indefinitely when trying to install these extensions.
force
Whether to force the installed version or not
preferred_state
The pecl extension state to install
salt.states.pecl.removed(name)

Make sure that a pecl extension is not installed.

name
The pecl extension name to uninstall